Home Forum Developers GUI 4.0 Dahdi and Queue correction

JRPassphrase Registration Control

In order to register on this site, you must first submit the passphrase below.

TODO list for each hardware target can be found as sticky topic in the corresponding forum


switchfinreseller
useravatar
User Info

Dahdi and Queue correction

Am I correcting this inbound issue correctly?
I am running an IP04 with rev 453.
I setup an inbound rule from an FXO port, (PSTN), that goes to a queue.
It has a time of day = all_the_time
The queue is activated upon an incoming call but the caller only hears a ring.
I tested it calling the queue directly from an internal phone, the queue works.
I found the inbound channel is not getting answered before the queue.

file = extensions_custom.conf
[DID_trunk_1_timeinterval_all_the_time]
exten=s,1,ExecIf($[ "${CALLERID(num)}"="" ],SetCallerPres,unavailable)
exten=s,2,ExecIf($[ "${CALLERID(num)}"="" ],Set,CALLERID(all)=unknown <0000000>)
exten=s,3,Goto(queues|6500|1)

I changed it to this:
exten=s,1,ExecIf($[ "${CALLERID(num)}"="" ],SetCallerPres,unavailable)
exten=s,2,ExecIf($[ "${CALLERID(num)}"="" ],Set,CALLERID(all)=unknown <0000000>)
exten=s,3,answer
exten=s,4,Goto(queues|6500|1)

and it works now.

Is this acceptable or is there a better way to fix this?

Thanks.


Administrator has disabled public posting

Board Info

Board Stats:   Total Users: 2587  Total Topics: 299  Total Polls: 1  Total Posts: 1727  Dormant
User Info:   Newest User :  user2553   Members Online: 0   Guests Online: 58
Online  There are no members online
Topic
New
Locked
Topic
New
Locked
Sticky
Active
New/Active
Sticky
Active
New/Active
New/Closed
New Sticky
Closed/Active
New/Locked
New Sticky
Locked/Active
Active/Sticky
Sticky/Locked
Sticky Active Locked
Active/Sticky
Sticky/Locked
Sticky/Active/Locked