Home Forum Developers GUI 4.0 no GUI access after firmware update

JRPassphrase Registration Control

In order to register on this site, you must first submit the passphrase below.

TODO list for each hardware target can be found as sticky topic in the corresponding forum


switchfinreseller
useravatar
User Info

no GUI access after firmware update

I just upgraded a PR1 from 499 to 629.
I checked reset config when doing this as I did not care about the curent config.
I did not keep network settings.
It came up on the default IP.
I logged in via the serial port, changed the IP to my network.
I cannot log in as admin.
It just shows loading for a second and never leaves the login screen.
This is the same if I'm on a Win7 box or my Mac, using any browser.
Anyone had this issue and know how to fix it?


Administrator has disabled public posting
switchfinreseller
useravatar
User Info

Re: no GUI access after firmware update

hmmm, maybe I need to recompile and start from scratch.
I just logged in via serial, typed asterisk -r and it said:

root@pr1:~> asterisk -r
asterisk: can't load library 'libspandsp.so.2'

:-(


Administrator has disabled public posting
switchfinreseller
useravatar
User Info

Re: no GUI access after firmware update

I compiled a new image and it's working now. Actually I bricked the unit with a image that failed checksum but made third one and all is well.  Ouch, that hurt for a moment.


Administrator has disabled public posting
admin
useravatar
User Info

Re: no GUI access after firmware update

Hi Jim,

So all fixed now? smile

Best Regards
Dimitar


Administrator has disabled public posting
Albi90
useravatar
User Info

Re: no GUI access after firmware update

Hi Dimitar/Jim

This issue happens every time you create a clean build you have to run make twice to rectify the issue.

Thanks
Jason


Administrator has disabled public posting
admin
useravatar
User Info

Re: no GUI access after firmware update

Oh Really smile

I will take a look tomorrow.

Best Regards
Dimitar


Administrator has disabled public posting
Chewi
useravatar
User Info

Re: no GUI access after firmware update

I know what the problem is and I'm fixing it now. I had the same problem with libtonezone.


Administrator has disabled public posting
Chewi
useravatar
User Info

Re: no GUI access after firmware update

Should be fixed now.


Administrator has disabled public posting
Albi90
useravatar
User Info

Re: no GUI access after firmware update

Thanks Chewi

Your a legend


Administrator has disabled public posting

Board Info

Board Stats:   Total Users: 2587  Total Topics: 299  Total Polls: 1  Total Posts: 1727  Dormant
User Info:   Newest User :  user2553   Members Online: 0   Guests Online: 63
Online  There are no members online
Topic
New
Locked
Topic
New
Locked
Sticky
Active
New/Active
Sticky
Active
New/Active
New/Closed
New Sticky
Closed/Active
New/Locked
New Sticky
Locked/Active
Active/Sticky
Sticky/Locked
Sticky Active Locked
Active/Sticky
Sticky/Locked
Sticky/Active/Locked