Home Forum Developers GUI 4.0 GUI problem

JRPassphrase Registration Control

In order to register on this site, you must first submit the passphrase below.

TODO list for each hardware target can be found as sticky topic in the corresponding forum


Crazypaqer
useravatar
User Info

GUI problem

Hello.
I have flashed my ip02 with freshly build switchfin (trunk 681) and have few major issues with GUI:
1) "missing /persistent/var/lib/asterisk/gui_backups/" alert on backup page.
2) Config files are not listed under file editor, and if you create new file and switch to another tab, it will get lost when you come back to file editor.
3) Nothing showing in System Status,except for pie image.
4) Hardware settings cannot be saved.
5) No files in MOH , although they are on device.
6) If you hit gui restart button it will show timer, but wont restart device.
Is it supposed to work this way or i'm doing something wrong?


Administrator has disabled public posting
Albi90
useravatar
User Info

Re: GUI problem

Hi

did you reset your configs when updating what version did you migrate from?
also its a good idea to empty your browser cache after GUI update.

thanks
Jason


Administrator has disabled public posting
Albi90
useravatar
User Info

Re: GUI problem

you should also check how much free space is on your ip02 lots of your issues sound symptomatic of your system not being able to write the temp files needed to output details to the gui


Administrator has disabled public posting
Crazypaqer
useravatar
User Info

Re: GUI problem

I didn't migrated, just full nand erase and flashed through u-boot.

Here is free space figure:

root@ip0x:~> df -k
Filesystem           1024-blocks    Used Available Use% Mounted on
/dev/root                17905     16332      1573  91% /
ubi0                    219120     73332    140952  34% /persistent
root@ip0x:~>

Not sure if this enough but still there are some free space available.


Administrator has disabled public posting
Albi90
useravatar
User Info

Re: GUI problem

Any chance you can email me your uImage

jason at ii-tec dot com


Administrator has disabled public posting
Albi90
useravatar
User Info

Re: GUI problem

Hi Ivan

I have loaded your uImage on my test system and its working fine, i can see the status page, and all sound files.  What browser are you using? im testing on chrome but we test the GUI on IE9 FF10 and chrome

Did this system have astfin on it before? we have had downgrade/upgrade issues before resulting in the user having to run a nand scrub.

Also your browser cache can cause lot of issues if you have previously loaded GUI 2.0 (we use a highly modified version of asterisk's ajam), so its always good to clear that.


Administrator has disabled public posting
Crazypaqer
useravatar
User Info

Re: GUI problem

Hello Jason,
I've used to have Atcome astfin (unit initially came with it), as for browsers i tried FF,IE,Safari and mobile Safari (all of them are current but not Beta version) and i never had a GUI < 4.0. As for downgrade, i did it through u-boot (nand erase and nand erase clean ) which i suppose should clear all the leftovers. Another thing is that i have a relativly new IP02 with 0.6 revision of the BF and new DM9000's.
Can there be a problem in u-boot or in enviroment variables?


Administrator has disabled public posting
Albi90
useravatar
User Info

Re: GUI problem

mmm the U-Boot vars could be an issue but usually that would cause more issues than just the GUI.

any chance I can get ssh and http access to the system, if possible can you PM or email me the details.

Thanks
Jason


Administrator has disabled public posting
Crazypaqer
useravatar
User Info

Re: GUI problem

Jason, thanks for your help , problem solved now.


Administrator has disabled public posting

Board Info

Board Stats:   Total Users: 2587  Total Topics: 299  Total Polls: 1  Total Posts: 1727  Dormant
User Info:   Newest User :  user2553   Members Online: 0   Guests Online: 116
Online  There are no members online
Topic
New
Locked
Topic
New
Locked
Sticky
Active
New/Active
Sticky
Active
New/Active
New/Closed
New Sticky
Closed/Active
New/Locked
New Sticky
Locked/Active
Active/Sticky
Sticky/Locked
Sticky Active Locked
Active/Sticky
Sticky/Locked
Sticky/Active/Locked